xorg-server-1.4 vs. Mesa-7.0.1 (with GLX)

Colin Guthrie gmane at colin.guthr.ie
Wed Sep 19 11:38:45 PDT 2007

Michel Dänzer wrote:
> On Wed, 2007-09-19 at 08:37 -0700, James Richard Tyrer wrote:
>> Michel Dänzer wrote:
>>> On Tue, 2007-09-18 at 21:05 -0700, James Richard Tyrer wrote:
>>>> Or, will 1.4 build against 7.0.1 and I am just missing something?
>>> xserver 1.4 indeed builds against mesa 7.0.1 (but no older version).
>>> What exactly is the problem when you try that?
>> And the reverse is true?  To use Mesa-7.0.1, you need xserver 1.4?
>> It is possible that I was trying to use Mesa-7.0.1 with an older version 
>> of xserver although I thought that I was using 1.4.
> You should be able to *use* Mesa 7.0.1 with an older X server, but it
> sounds like you're still referring to building the X server GLX code,
> which indeed tends to have quite a strict dependency on the version of
> the Mesa source tree.

FWIF, in Mandriva we use Xserver 1.3 and Mesa 7.0.1. There are some
patches kicking around so that everything builds fine too.


More information about the xorg mailing list