[Fwd: Re: DRI and OpenGL problem with GM965]

Svetlana Atanasova svetlana at netissat.bg
Fri Sep 28 09:39:48 PDT 2007

In addition to say that today I have tried the newest versions of drm 
+driver-intel +mesa(even mesa doesn't compiles clean before editing some
include paths and duplicate type definitions) but the result is the same 
- no DRI and the same error - when running glxgears for example

libGL error: drmMap of framebuffer failed (Invalid argument)

or starting X with AIGLX

(EE) AIGLX error: drmMap of framebuffer failed (Invalid argument)(EE) 

-------- Original Message --------
Subject: 	Re: DRI and OpenGL problem with GM965
Date: 	Fri, 28 Sep 2007 12:34:20 +0300
From: 	Svetlana Atanasova <svetlana at netissat.bg>
To: 	Wu Nian <nian.wu at intel.com>
CC: 	xorg at lists.freedesktop.org
References: 	<46FBF23E.1030901 at netissat.bg> 
<1190943253.18726.1.camel at gfx-nwu>


   thank you for reply, it was the first I have tried - to install drm, 
intel video driver
and mesa from git, but the result was the same. After trying different 
of kernel modules, mesa drivers and video drivers I discovered that 
problem is due
to xf86 video intel driver.
 Now I've installed again 2.1.0 driver and the exact error when xserver 
lockup is

Error in I830WaitLpRing(), timeout for 2 seconds
pgetbl_ctl: 0x3ff80001 pgetbl_err: 0x0
ipeir: 0 iphdr: 60020100
LP ring tail: 1e570 head: 1e3b0 len: 1f001 start 0
Err ID (eir): 0 Err Status (esr): 0 Err Mask (emr): ffffffdf
instdone: ffe5fafd instdone_1: ffff3
instpm: 0
memmode: 0 instps: 401f02e
HW Status mask (hwstam): fffedffe
IRQ enable (ier): a2 imr: fffe0000 iir: 0
acthd: 2dd8308 dma_fadd_p: 2dd8308
ecoskpd: 307 excc: 0
cache_mode: 6800/180
mi_arb_state: 44
TS_CTL 0  TS_DEBUG_DATA ff9df68e
TD_CTL 0 / 0
space: 130616 wanted 131064

FatalError re-entered, aborting

Best Regards,

Wu Nian wrote:

>On Thu, 2007-09-27 at 21:11 +0300, Svetlana Atanasova wrote:
>>    sorry if this is previously discussed but I'm quite new to this list.
>>I have HP 6710s laptop with slackware 12.0 (kernel, xserver 
>>1.3.0- slack 12 default)  and I have troubles with
>>glx. With slackware 12.0 default driver - xf86-video-intel-2.0.0 there 
>>is DRI but colors
>>looks terrible - there are visible lines on color gradient patterns. 
>>With driver provided
>>in slackware distribution in directory /patches - 
>>xf86-video-intel-2.1.0  colors OK, DRI working, but when I test with GL
>>screensaver  X server lockups with something for insufficient free 
>>memory to allocate in logs I don't have these logs now.
>>I've downloaded the latest intel drivers from 
>>http://www.intellinuxgraphics.org and after compiling them I don't have DRI
>>I got the following error in logs:
>>(EE) AIGLX error: drmMap of framebuffer failed (Invalid argument)(EE) 
>Please also try to update DRM(libdrm and drm kernel module).
>-Nian Wu
>>AIGLX: reverting to software rendering
>>and the following warnings (if it's helpful):
>>(WW) intel(0): Removed DRI frontbuffer mapping in compatibility mode.
>>(WW) intel(0): DRIGetDeviceInfo will report incorrect frontbuffer handle.
>>So I can't get my videocard working properly with any drivers, please 
>>help whith any ideas or patches, etc.
>>Thanks in advance!
>>Best Regards,
>>xorg mailing list
>>xorg at lists.freedesktop.org
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.x.org/archives/xorg/attachments/20070928/33fc9ba7/attachment.html>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: file:///tmp/nsmail.txt
URL: <http://lists.x.org/archives/xorg/attachments/20070928/33fc9ba7/attachment.txt>

More information about the xorg mailing list