xserver compile problem

Daniel Stone daniel at fooishbar.org
Sun Aug 24 15:45:32 PDT 2008

On Sun, Aug 24, 2008 at 06:04:46PM -0400, Chuck Robey wrote:
> I updated my sources, and  now I can no longer compile the xserver.  So, either
> it could be my version (I'm really inept at git, I wish there was either a
> cvs/git or svn/git gateway, I can use those fine) or maybe the part of the
> xserver I'm trying to compile is temporarily broken, just let me know, and I'll
> work the appropriate workaround.
> The problem I'm seeing is in xserver/Xi, the file Xi/xiproperty.c.  Every use of
> devicePropertyNotifyEvent gets me an error, because it's not defined anywhere.
> I grepped all of my sources, I tried using my tags file, nothing can find that
> devicePropertyNotifyEvent definition.  I tried cleaning things and building from
> scratch, I also tried updating my sources, no help.  The first error I get is in
> that xiproperty,c line 194, but there are others (fix one, they all get fixed).
>  So, is it maybe a problem with my sources, or should I arrange not to build Xi
> somehow?

Update inputproto.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 197 bytes
Desc: Digital signature
URL: <http://lists.x.org/archives/xorg/attachments/20080825/c8cbc616/attachment.pgp>

More information about the xorg mailing list