Problem starting X server on debian lenny

dolphinling lists at
Fri Jul 17 11:04:30 PDT 2009

Imtiaz Ahmed wrote:
> Hi,
> I tried the intelgraphics driver version 2.7 but still the same error 
> with no change at all, Even today i tried to install Ubuntu hardy 
> desktop and it gives the error
> (EE) intel(0): No valid modes.
> EE) Screen(s) found, but none have a usable configuration
> and stuck up.
> I googled around and found many posts like this but almost all are 
> related to laptops where there are 2 displays internal and external but 
> this is  a Desktop  PC wiht Intel 965G video graphic on board.

What kind of monitor connection is it (VGA, DVI, ...)? Also, is there anything 
between the graphics card and the monitor, such as a KMS switch?

The driver version in Hardy is even older that the one in Lenny. If you don't 
mind trying another Ubuntu, could you try Jaunty? Even better would be if you 
could jaunty but with a newer kernel and xf86-video-intel.

That's about all I can think of, hopefully that's enough to push you in the 
right direction to fix it or someone who knows better will come along.


More information about the xorg mailing list