Problem starting X server on debian lenny

Justin P. Mattock justinmattock at
Fri Jul 17 11:52:38 PDT 2009

Imtiaz Ahmed wrote:
> Hi,
> I tried the intelgraphics driver version 2.7 but still the same error 
> with no change at all, Even today i tried to install Ubuntu hardy 
> desktop and it gives the error
> (EE) intel(0): No valid modes.
> EE) Screen(s) found, but none have a usable configuration
> and stuck up.
> I googled around and found many posts like this but almost all are 
> related to laptops where there are 2 displays internal and external 
> but this is  a Desktop  PC wiht Intel 965G video graphic on board.
> Any help in this regard will be highly appreciated.
> regards,
> Imtiaz
> Justin P. Mattock wrote:
>> Julien Cristau wrote:
>>> On Mon, Jul 13, 2009 at 11:14:10 -0700, Justin P. Mattock wrote:
>>>>    From looking at this:
>>>> (II) intel(0): EDID for output VGA
>>>> (II) intel(0): Output VGA disconnected
>>>> (EE) intel(0): No valid modes.
>>>> (II) UnloadModule: "intel"
>>>> (II) UnloadModule: "vgahw"
>>>> (II) Unloading /usr/lib/xorg/modules//
>>>> (II) UnloadModule: "vbe"
>>>> (II) Unloading /usr/lib/xorg/modules//
>>>> (II) UnloadModule: "int10"
>>>> (II) Unloading /usr/lib/xorg/modules//
>>>> (EE) Screen(s) found, but none have a usable configuration.
>>>> somehow the xserver is not recognizing the module
>>>> from the kernel, do you have it loaded?
>>> No, this has nothing to do with kernel modules.  The driver just 
>>> doesn't
>>> seem to detect any connected monitors.
>>> Cheers,
>>> Julien
>> Sh^t I swear that said module
>> (I need glasses!!)
>> Justin P. Mattock
Seems this has been an earlier issue as well:
even though it's ubuntu, might give some useful info.

I have a machine that has an intel gpu, but it might take some time
to get up and running to see if I hit this as well.

Justin P. Mattock

More information about the xorg mailing list