Driver problem: Chips and Technologies F65555 HiQVPro

Donald Kayser xorg at
Mon Jul 27 19:28:35 PDT 2009

I recently worked with the chips driver on an embedded PPC platform. I  
found that the chips driver does not work with the newer versions  
because of the libpci access changes. I rewrote the driver, but  
stripped out anything but support for the 65530 which is part of my  
embedded platform which, and is not using the latest Xserver yet. I  
did not debug the newest version of Xserver beyond seeing that the  
first call in the driver to obtain specific PCI information about the  
card returned an error.

I will look back into my notes to find out which call fails and report  
back. Maybe you will have luck with someone fixing that call.


On Jul 27, 2009, at 5:38 PM, Moyano, Gustavo wrote:

> Hi all,
> I'm having problems setting up Xorg on my laptop.  I'm migrating  
> from FreeBSD 4.11 to FreeBSD 7.2 but seems that the "chips" driver  
> does not recognize the hardware.  I had no problems with FreeBSD  
> 4.11 but 7.2 is not working.  My laptop is a Toshiba Satellite 330CDS:
>    * Processor
>          o Intel Pentium (1.8 volt) with MMX technology, running at  
> 266MHz
>          o 512KB pipelined burst SRAM level 2 cache
>          o 66MHz bus clock speed
>    * Memory
>          o 32MB EDO DRAM standard
>    * Disk Drives
>          o 4.1 gigabyte hard disk drive
>          o 1.44MB, 3.5" diskette drive (integrated)
>    * CD-ROM
>          o 20X (max) CD-ROM module (integrated)
>    * Display System
>          o 12.1" diagonal, 800 x 600 resolution color display
>          o Color bright dual scan
>          o C & T HiQVideo PCI (65555) video controller
>          o 2MB Video memory (EDO DRAM)
>          o 64-bit BitBLT graphics acceleration
>          o 66MHz local bus clock speed
>          o Super Video Graphics Array (SVGA) compatible display
> I'm attaching the xorg.conf file created when I ran "X -configure"  
> and the log file created when I ran "X -config ..."
> I don't know if something changed inside the driver since it was  
> working fine on FreeBSD 4.11, which used XFree86.
> Could someone give me a little help, please?
> Thanks is advance,
> ggmoy
> <><Xorg. 
> 0.log>_______________________________________________
> xorg mailing list
> xorg at

More information about the xorg mailing list