No mouse, no keyboard in X

jazzbo bo.forslund at
Tue Mar 15 18:46:33 PDT 2011

Xorg no longer react to usb mouse or usb keyboard after starting up. The gdm3
login screen doesn't react to keyboard input or mouse movements.

Thought usb port might dead, tried to plug the mouse into the the usb port
at the front of the pc and the mouse started to live. Tried to plug the
keyboard into an usb port at the front of the pc and it started to live too.

Thought it was solved, but no.  The gdm3 screen didn't react to keyboard or
mouse. Plugged  keyboard and mouse into the usb ports at the back of the pc
and keyboard and mouse worked again.

Then i tried to unplug the mouse and plug it back into the same jack and it
started to work. Same with the keyboard.

The Xserver doesn't find the mouse or keyboard unless keyboard and mouse are
unplugged / plugged in.

The computer is a Scaleo H. OS is Linux. Debian Wheezy.

Ahy ideas??


$ Xorg -version

X.Org X Server 1.7.7
Release Date: 2010-05-04
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.32-5-amd64 x86_64 Debian
Current Operating System: Linux pc124 #1 SMP PREEMPT Wed Feb 23
14:20:51 CET 2011 x86_64
Kernel command line: BOOT_IMAGE=/vmlinuz-
root=UUID=ffbdd377-ff2d-4549-a101-7736dbddf1af ro quiet
Build Date: 12 January 2011  02:59:50AM
xorg-server 2:1.7.7-11 (Cyril Brulebois <kibi at>) 
Current version of pixman: 0.16.4
	Before reporting problems, check
	to make sure that you have the latest version.

View this message in context:
Sent from the Free Desktop - xorg mailing list archive at

More information about the xorg mailing list