Xorg 1.13 on gentoo blocks joysticks

Valentin Ochs a at 0au.de
Thu Jan 10 05:07:00 PST 2013

Hi all,

My xorg-server (1.13, but also tested with 1.12.4) on Gentoo somehow
keeps my joysticks busy.

It's supposed to ignore 'joystick' class inputs, and says that it does
(see [1]), but when trying to access e.g. /dev/input/js0, I get an

Killing X or switching to a virtual terminal frees it. I'm getting the
same results with Linux 3.6.6 and 3.7.1, with 3.4.4 I can access the
device but do not receive any events while I'm in X.

I've tried running lsof +D /dev/input, but X does not actually get
listed as using the joystick devices, nor do any other processes.

Running a blank X with just xterm in it and trying to access the
devices gets the same result.

xf86-input-joystick is not installed.

If anybody could give me some pointers on how to further shoot this
trouble, I'd be very grateful. Please send a CC to this address, as I
am not subscribed to the ML.


[1] current Xorg log:    http://p.0au.de/42c58600
[2] current Xorg config: http://p.0au.de/593dfd53
[3] Kernel config:       http://p.0au.de/1421ea9f

More information about the xorg mailing list