egunther at egunther at
Sun Jan 27 06:53:26 PST 2013


Thank You very much for the reply.  Unfortunately I am kind of stumbling
in the dark here and so tried what I 'got' or thought might work.  What I
interpreted you to mean was that I 'could' copy another file, which in
this case needed to be 64, because both the software and the OS are 64.

I copied from /usr/lib64/



and X froze/crashed.

Now my OpenSuSE is messed up.


I made some progress, i am stuck with a console, but I just wanted to get
back to you for the help.
So am using xp.

I Did try to rm the newly copied from the


directory, but nothing appeared to change.

     Otherwise it appeared from what you had said that I would need
to find a version of libX11 that would include that ?compile flag?,  or
had used that option to compile.  That didn't seem like I could  follow
that through.

     I have asked on the OpenSuSE mailing list, and got a response to
the same or similar issue that I should:


run your application


Which I tried, and also tried to do that before installing softimage, but
same problem.



On Sonntag, 27. Januar 2013 09:35:19 CEST, Eric Gunther wrote:

    The error is:

    /usr/Softimage/Softimage_2011/Application/bin/XSI.bin: symbol lookup
error: /usr/Softimage/Softimage_2011/Application/bin/
undefined symbol: _XGetRequest

Softimage comes with it's own version of libXext, that version was linked 
against libX11 with exported _XGetRequest.
Your version of libX11 will not export the symbol (thus the error

readelf -swf /usr/lib/libX11*.so | grep _XGetRequest

and Softimage does likely not bring it's own libX11

Either you're lucky, softimage ships libXext for no reason and you can simply
move it away (so that the system version is used) or (cleaner solution,
with the before could emerge later during use) you need a version of libX11
which exports the symbol.

That's sth. you've to ask openSuSE folks about then.

It may also work to copy the 32bit variant from the Distro package to the 
Softimage binary dir as (if softimage is 32bit)

    Softimage is not recommended for this distro, but as far as I can tell
it is common to have problems with linux.

Software requiring .Net v3 is not recommended for .Net v2, but as far as I
can tell
it is common to have problems with the ntos kernel"

Sounds silly? Is.


More information about the xorg mailing list