connection to xserver became forbidden after Xorg started

A A wempwer at
Mon Nov 18 04:25:00 PST 2013

Yesterday I had a rather uncommon situation I can't wrap my head
around. I run Slackware 13.37 x64, start my system inside tty. I
logged in and run startx as usual. Flubxox, my WM of choice started
correctly. Then, I tried to use ristretto to open on image stored on
SAMBA share that is added to /etc/fstab and has been mounted
automatically during bootup. My LAN connection is handled by USB-RJ45
adapter which is pretty unstable sometimes. During opening an image,
ristretto froze. I already knew that this means network problems with
accessing remote share so I re-run inet script which reconfigures
networking on Slackware. Then, I found ristretto process with `ps aux'
and killed it. It didn't stop immediately and was still present in `ps
aux' output but it was enclosed within square brackets. I don't
remember if I tried to kill it again with -9 or it closed by
itself. However, after this incident, I wasn't able to start any X
programs. When I tried to start ristretto, xeyes, wmctrl I got this:

can't open display
Error: Can't open display: :0.0

At the same time I had Emacs, firefox and uxterm running inside
fluxbox. It seems like some program wiped all entries in xhost and
forbid me from accessing local X server. I realize that situation is
pretty strange. There are no related information in Xorg log or in
dmesg. Have you ever encountered a similar situation? My version of
both Slackware and Xorg are pretty old, maybe there are similar bugs

X -version

X.Org X Server 1.9.5
Release Date: 2011-03-17
X Protocol Version 11, Revision 0
Build Operating System: Slackware 13.37 Slackware Linux Project
Current Operating System: Linux #3 SMP Sat Apr 9 22:49:32
CDT 2011 x86_64
Kernel command line: auto BOOT_IMAGE=Slackware ro root=804 vt.default_utf8=1
Build Date: 17 March 2011  10:50:17PM

Current version of pixman: 0.20.2
        Before reporting problems, check
        to make sure that you have the latest version.

More information about the xorg mailing list