No video after resume from suspend

Markus Strobl mstrobl2 at
Thu Apr 14 16:59:00 UTC 2016

I haven't had the exact problem you're having, but I have seen similar issues with suspend. In my case the system would lock up when going to suspend, requiring a power cycle to come back.
Turned out to be caused by multiple frame buffer drivers being loaded at the same time. I had uvesafb as well as efifb loading at boot. The system worked fine until trying to suspend. I removed uvesafb from the kernel and everything worked fine.
Just a thought,Markus

      From: "russell.poffenberger at" <russell.poffenberger at>
 To: xorg at 
 Sent: Thursday, April 14, 2016 11:29 AM
 Subject: Re: No video after resume from suspend

Thanks for the info Thomas.

ctrl+alt+f2 does not appear to do anything.I see no visible effects when the display is running normally (before suspend)nor does it wake the screen after resuming from suspend.
Failsafe mode also fails to restorethe display when resuming.
One odd note I found is that I havesome difficulty with hibernate also. If I attempt to hibernate this system,it takes about 2 minutes for it to actually go into hibernation. I havetried many things to see what is going on including booting with parameterssuch as ignore_loglevel, initcall_debug, no_console_suspend, etc. but thereare no messages indicating why it takes so long to hibernate.
The funny thing is that if I suspend/resume,then rlogin to the machine and invoke hibernate, it goes into hibernationin about 10 seconds. Booting and restoring from hibernation restores everything(including the screen) right where it ought to be.

My workaround for now is to make a scriptwith the following commands
rtcwake -m mem -s 5;systemctl hibernate
Although it takes longer to recoverthan suspend/resume, it is within acceptable parameters.

Russ Poffenberger | System Architecture Group
Phone:  +1 / 408 / 635-6049
russell.poffenberger at
Xcerra Corporation, LTX/Credence Division
1355 California Circle
Milpitas, CA 95035, USA

| From: | Thomas Lübking <thomas.luebking at> |
| To: | russell.poffenberger at |
| Date: | 04/14/2016 03:47 AM |
| Subject: | Re: No video after resume from suspend |

On Wed, Apr 13, 2016 at 05:44:27PM -0700, russell.poffenberger at xcerra.comwrote:
>When I put the system to sleep, after resuming from sleep, the system
>comes alive (I can rlogin fine), but there is no video signal, as reported
>by the monitor and a blank display. No amount of pressing keys or moving
>the mouse have any effect.

Can you switch to another VT (ctrl+alt+f2) and does the framebuffer
change get you a signal?

>Is there something I can send or do to wake the video up, at leastto try
>and understand what is not resuming properly?

No idea whether that's related, but at least the nvidia blob has/d trouble
moving data between VRAM and RAM across STR.

Are you running gnome and does it also happen with a failsafe login?
(Anything that's not a GL composited DE)


xorg at X.Org support
Your subscription address: %(user_address)s

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the xorg mailing list