help with Xorg (Adam Jackson)

Alan Corey alan01346 at gmail.com
Wed Aug 2 23:44:52 UTC 2017


Is there any window manager like fvwm, openbox, lxde, kde, gnome?
What you do next depends on what you're running because each OS has
its own package manager, its own way of fetching and installing
things.  Apt-get install works for Debian, Rasbian, maybe Ubuntu.
Some have Yum, there's about nothing in common.  If you have it
(Debian/Raspbian/Ubuntu) doing:
dpkg-query -l > somefile.txt in an xterm window will get you a list of
what's installed.  It's pkg_info under OpenBSD.  Sounds like X is
working but there's not much else.

On 8/2/17, Perez Rodriguez, Humberto I
<humberto.i.perez.rodriguez at linux.intel.com> wrote:
> Hi Alan,
>
> definitely this is not a normal installation, because all the drivers
> goto /opt/X11R7 in a isolate environment.
>
> after type startx i got a black desktop, but i am able to open a
> terminal, to create folders and navigate by the system through the
> folders, but that i want to do is to have the same environment like Xorg
> does
>
>
> On 8/2/2017 4:21 PM, Alan Corey wrote:
>> Wow, sounds like not much is installed, like this wasn't a normal
>> installation.  What happens if you type startx to start x?  It should
>> run xinit after a few steps.  You may not even have a window manager.
>> Sounds like when I tried getting X running on Raspbian Jessie Lite.
>>
>> On 8/2/17, Perez Rodriguez, Humberto I
>> <humberto.i.perez.rodriguez at linux.intel.com> wrote:
>>> Thanks, in fact i dont know to much about xorg  and your help here
>>> always is welcome :)
>>>
>>> after run it the both commands with the same user i am now able to see
>>> in a little white box the terminal with xterm, but now the big question
>>> is how can i display the windows, wallpapers and everything else like
>>> xorg does by default ?
>>>
>>>
>>>
>>> On 8/2/2017 7:41 AM, Thomas L├╝bking wrote:
>>>> On Tue, Aug 01, 2017 at 02:43:55PM -0500, Perez Rodriguez, Humberto I
>>>> wrote:
>>>>> after try the command below, i get the following error :
>>>>>
>>>>> xterm: Xt error: Cant open display: :0
>>>>>
>>>>>
>>>>> as a comment, i've tried as well with "export DISPLAY=:[0-6]" without
>>>>> success :(
>>>> No offense, but you didn't happen to switch back to the VT from where
>>>> you launched X11 and interrupted that process in order to enter the
>>>> xterm command, did you?
>>>> IOW: Is the X11 server still running on another VT when you tried this?
>>>> ps aux | grep Xorg
>>>>
>>>> Otherwise: Did you run both commands as the same user?
>>>>
>>>> The number behind the colon btw. does not refer to the VT.
>>>>
>>>> Cheers,
>>>> Thomas
>>>
>>
>
>


-- 
-------------
No, I won't  call it "climate change", do you have a "reality problem"? - AB1JX
Impeach  Impeach  Impeach  Impeach  Impeach  Impeach  Impeach  Impeach


More information about the xorg mailing list