help with Xorg (Adam Jackson)

Carsten Haitzler (The Rasterman) raster at rasterman.com
Thu Aug 3 00:00:52 UTC 2017


On Wed, 2 Aug 2017 10:46:30 -0500 "Perez Rodriguez, Humberto I"
<humberto.i.perez.rodriguez at linux.intel.com> said:

> Thanks, in fact i dont know to much about xorg  and your help here 
> always is welcome :)
> 
> after run it the both commands with the same user i am now able to see 
> in a little white box the terminal with xterm, but now the big question 
> is how can i display the windows, wallpapers and everything else like 
> xorg does by default ?

xorg does not display these by default. xorg does NOTHING by default. all of
this stuff is done by your login session apps like the window manager and so
on. you've gotten past your issue. the xserver works. it worked before (just
was black). xorg, its rendering, drivers, input work. you have a terminal. you
can type in it. you want to start a whole x SESSION. that's what things like
startx, xdm, gdm, kdm, slim, lightdm, etc. etc. etc. do - they do all of this
and go launch everything (and in the case of all by startx also handle logging
in a specific user and authenticating them if needed).

this is what all those desktops - enlightenment, gnome, kde, xfce do. they
provide all the thing you CALL an xorg desktop. each is its own project. you
want to run one of those in your login session. as above - these tools
generally would do that for you. they may use your ~/.xsession script to decide
what to do or ~/.xinitrc or provide a gui to select a session. you would need
something installed.

you could install more basic window manages with far less stuff  like twm.
fvwm, etc. etc. too... but you will want something else than just xorg. xorg is
basically a driver with an ipc/network front end that apps talk to to do the
rest.

> On 8/2/2017 7:41 AM, Thomas L├╝bking wrote:
> > On Tue, Aug 01, 2017 at 02:43:55PM -0500, Perez Rodriguez, Humberto I 
> > wrote:
> >>
> >> after try the command below, i get the following error :
> >>
> >> xterm: Xt error: Cant open display: :0
> >>
> >>
> >> as a comment, i've tried as well with "export DISPLAY=:[0-6]" without 
> >> success :(
> >
> > No offense, but you didn't happen to switch back to the VT from where
> > you launched X11 and interrupted that process in order to enter the
> > xterm command, did you?
> > IOW: Is the X11 server still running on another VT when you tried this?
> > ps aux | grep Xorg
> >
> > Otherwise: Did you run both commands as the same user?
> >
> > The number behind the colon btw. does not refer to the VT.
> >
> > Cheers,
> > Thomas
> 


-- 
------------- Codito, ergo sum - "I code, therefore I am" --------------
The Rasterman (Carsten Haitzler)    raster at rasterman.com



More information about the xorg mailing list