AMD Radeon RX550 not detected

Felix Miata mrmazda at
Tue Aug 15 01:29:34 UTC 2017

Attila Kinali composed on 2017-08-15 02:19 (UTC+0200):

> I got myself a Radeon RX550 and tried to get it working using OSS drivers
> under linux. Unfortunately I was not successful. Despite what I tried,
> which Howto I read, I always get the same error: (EE) No devices detected.

> I have read that other people have been using this very card with
> OSS drivers, but I cannot figure out what they did differently

Can you provide URLs where success was described?

> I am running debian/testing, with kernel 4.12.7, amdgpu 1.3.0, mesa 17.1.5
> I attached the relevant log files.

> If someone could give me a hint what I could try, this would me much
> appreciated.

Just suggestions, as I don't have an RX550:

1-<> shows it hasn't quite
been 4 months since the product's release. xorg-driver-ati at is
probably the best mailing list to ask for help for a product as new as yours.
Driver writers can see your plight and respond. There might be a bug you can get
them to fix.

2-Try removing amdgpu and radeon drivers, so that Xorg can try its integrated
modesetting driver, mainly to see if your device can be found by Xorg at all.

3-If you haven't looked at yet, do.
Arch Linux docs are among the best.
"The wise are known for their understanding, and pleasant
words are persuasive." Proverbs 16:21 (New Living Translation)

 Team OS/2 ** Reg. Linux User #211409 ** a11y rocks!

Felix Miata  ***

More information about the xorg mailing list