AMD Radeon RX550 not detected

Michel Dänzer michel at
Tue Aug 15 01:47:27 UTC 2017

On 15/08/17 09:19 AM, Attila Kinali wrote:
> Hi,
> I got myself a Radeon RX550 and tried to get it working using OSS drivers
> under linux. Unfortunately I was not successful. Despite what I tried,
> which Howto I read, I always get the same error: (EE) No devices detected.
> I have read that other people have been using this very card with
> OSS drivers, but I cannot figure out what they did differently
> I am running debian/testing, with kernel 4.12.7, amdgpu 1.3.0, mesa 17.1.5
> I attached the relevant log files.


> [    10.640] (WW) xf86OpenConsole: setpgid failed: Operation not permitted
> [    10.640] (WW) xf86OpenConsole: setsid failed: Operation not permitted

I wonder if these could be relevant?

> [    10.644] (II) [KMS] Kernel modesetting enabled.

This message (with no following error messages from the driver) means
that the amdgpu driver's probe hook succeeds and returns TRUE.

> [    10.648] (EE) No devices detected.
> [    10.648] (EE) 
> Fatal server error:
> [    10.648] (EE) no screens found(EE) 

So this looks like a Xorg bug. No idea offhand what's happening,
somebody who can reproduce this needs to trace the code execution from
amdgpu_kernel_mode_enabled returning TRUE to xf86BusConfig printing "No
devices detected." to find out what goes wrong in between.

Earthling Michel Dänzer               |     
Libre software enthusiast             |             Mesa and X developer

More information about the xorg mailing list