Ryzen 4500U Integrated graphics - found no way to make it work

Qu Wenruo quwenruo.btrfs at gmx.com
Tue Nov 24 09:32:34 UTC 2020

On 2020/11/24 上午4:16, Martin Wagner wrote:
> Dear mailing list,
> for my new job I got a just as new HP Probook X360 435 G7, featuring
> the AMD CPU/GPU I named above (Ryzen 5 4500U) - and I found no way so
> far to make it work in any Linux I could think of. I get either a low
> resolution (SVGA on older kernel or current 5.8 kernel with nomodeset
> option) or a black screen on boot on any distribution I tried so far
> with a recent kernel (which is Mint, Ubuntu Mate, Fedora, openSUSE,
> Manjaro, Debian, maybe one or two I forgot).

I have a ThinkPad T14 with 4750U, with current upstream kernel (from
Arch) it works like a charm now.
It had some small problems, related to the GPU reset (worked around by
disabling iommu)

But now from the internal display to external mutil-monitor setup using
DP alt mode with MST, it works perfectly, and some light games is no
problem either.

And not to be a meme guy, but the only distro I tried on that laptop
(and is still using) is Arch, and considering the newer hardware needs
newer kernel/mesa, it's not a surprise.

So I guess either the internal display or the kernel/mesa fresshness is

But first thing first, in case you're hitting the GPU reset bug, please
try boot every kernel with "amd_iommu=off", which seems to greatly
reduce the chance if not completely solved it.

> First of all: A lot of troubleshooting happened here already, there you
> can also find a ton of log outputs:
> https://forums.linuxmint.com/viewtopic.php?f=46&t=334399

Not a distro I would choose for newer hardware though.

First thing first, from your Xorg log:
[     4.694] (EE) open /dev/dri/card0: No such file or directory
[     4.694] (WW) Falling back to old probe method for modesetting
[     4.694] (EE) open /dev/dri/card0: No such file or directory

This shows your kernel doesn't detect the iGPU at all.

So you indeed need newer kernel to at least detect the iGPU.

For newer kernel, you still need extra mesa update to use the newer iGPU.

I'm not surprised that Manjaro got further, but since it's still behind
official Arch, you can't expect more.


> (Linux Mint is my preferred distribution pretty much since it came into
> existence.)
> Can you offer any way to make it work, any kind of help beyond what I
> already tried? Post #27 on that forum thread also contains an
> Xorg.0.log.old, which is one of the black screen boots of course.
> Please let me know if I can provide you any further information. Thank
> you.
> Tc, Martin
> _______________________________________________
> xorg at lists.x.org: X.Org support
> Archives: http://lists.freedesktop.org/archives/xorg
> Info: https://lists.x.org/mailman/listinfo/xorg
> Your subscription address: %(user_address)s

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 488 bytes
Desc: OpenPGP digital signature
URL: <https://lists.x.org/archives/xorg/attachments/20201124/0b4352b9/attachment.sig>

More information about the xorg mailing list