Dead keys not working.

Jose Otero otero_jose at
Thu Aug 12 19:00:08 UTC 2021


I am unable to make dead keys work in my system, so maybe someone can point me to the right path.

Sorry for throwing in FreeBSD specific terms in this firs paragraph, but just for context:
I am using FreeBSD (13.0). First, I had installed the metaport (i.e. metapackage, the whole thing) for X.Org; and dead keys worked.
A few weeks ago I had to reinstall all the ports (user programs), including X.Org. Going minimalistic I installed xorg-minimal, x11-drivers/xf86-input-keyboard, x11-drivers/xf86-input-mouse, x11/libXinerama, x11-fonts/libXft, x11/xorg-docs, and a couple of fonts (x11-fonts/xorg-fonts-truetype, x11-fonts/dejavu, x11-fonts/terminus-ttf). Dead keys do not work now, so I am likely missing some library.
Just to complete the background, I am using suckless windon manager (dwm) and terminal (st). Just in case, dead keys don't work either in xterm, I already tried. Or other applications for that matter, e.g. qutebrowser.

Now the details:

If I try, for example, to write 'á' by typing '´' and then 'a'. It only writes 'a'. This is the info gather by xev for these events:

Now, if I set my keyboard to us(intl) with "setxkbmap -layout us -variant intl". Now I am able to write 'á'. xev info for this case:

This is my 'locale' configuration:

But I don't think it is a problem with the locale configuration of the system, because in my console (vt) or in the terminals (ttyv) the dead keys work as intended. It is specificaly inside where it doesn't work. I did try anyway changing the locales to 'charset=iso-8859-1, lang=es_ES.ISO8859-1; and charset=UTF-8, lang=es_ES.UTF-8. And it didn't work in any case.

This is the configuration of the keyboard (cat /usr/local/etc/X11/xorg.conf.d/keyboard-es.conf):
Section "InputClass"
        Identifier      "KeyboardDefaults"
        MatchIsKeyboard "true"
        Option          "XkbModel"      "pc104alt"
        Option          "XkbLayout"     "es"

I don't have a 'xorg.conf'. If I generate one this would be it (Xorg -configure):

And this is the Xorg.0.log:

By the way, in '/usr/local/lib/X11/locale' I don't see any directory for 'es': I do have installed 'x11/libX11', so I am not sure if I am missing a 'es_ES.UTF-8' directory there or not.

I hope I am giving enough information. Any help that directs me to a possible solution, even if it is not a straight answer, will be appreciate it.

Thanks in advance for your help.

P.s.: I sent unintentionally an unfinished version of this email to the list. I apologize and please disregard that message.

José M. Otero R.


Computer Scientist.

Master of Business Administration.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the xorg mailing list