Dead keys not working.

Ilya Anfimov ilan at
Fri Aug 13 08:39:13 UTC 2021

On Thu, Aug 12, 2021 at 07:00:08PM +0000, Jose Otero wrote:
>    Hi,
>    I am unable to make dead keys work in my system, so maybe someone can
>    point me to the right path.
>    Sorry for throwing in FreeBSD specific terms in this firs paragraph, but
>    just for context:
>    I am using FreeBSD (13.0). First, I had installed the metaport (i.e.
>    metapackage, the whole thing) for X.Org; and dead keys worked.
>    A few weeks ago I had to reinstall all the ports (user programs),
>    including X.Org. Going minimalistic I installed xorg-minimal,
>    x11-drivers/xf86-input-keyboard, x11-drivers/xf86-input-mouse,
>    x11/libXinerama, x11-fonts/libXft, x11/xorg-docs, and a couple of fonts
>    (x11-fonts/xorg-fonts-truetype, x11-fonts/dejavu, x11-fonts/terminus-ttf).
>    Dead keys do not work now, so I am likely missing some library.
>    Just to complete the background, I am using suckless windon manager (dwm)
>    and terminal (st). Just in case, dead keys don't work either in xterm, I
>    already tried. Or other applications for that matter, e.g. qutebrowser.
>    Now the details:
>    If I try, for example, to write 'a' by typing ''' and then 'a'. It only
>    writes 'a'. This is the info gather by xev for these events:

 Well, I don't know exactly what is the path of X11 datafiles
on FreeBSD, it may be different than /usr/share/X11/

 However, considering that it is /usr/share/X11 -- you'll need the following
for deadkeys to work on C.UTF-8 locale:

File: /usr/share/X11/locale/locale.alias

C.UTF-8                                 en_US.UTF-8
C.UTF-8:                                        en_US.UTF-8

File: /usr/share/X11/locale/locale.dir

en_US.UTF-8/XLC_LOCALE                  en_US.UTF-8
en_US.UTF-8/XLC_LOCALE:                 en_US.UTF-8

File: /usr/share/X11/locale/en_US.UTF-8/Compose
<dead_acute> <a>                        : "ц║"   aacute # LATIN SMALL LETTER A WITH ACUTE

(Sorry about symbol in quotes, it should be utf-8 dead acute)

File: /usr/share/X11/locale/en_US.UTF-8/XI18N_OBJS

XLC     common/xlcUTF8Load      _XlcUtf8Loader          # XLC_open
XOM     common/xomGeneric       _XomGenericOpenOM       # XOM_open
XIM     common/ximcp    _XimOpenIM _XimRegisterIMInstantiateCallback  _XimUnRegisterIMInstantiateCallback # XIM_open    XIM_register XIM_unregister

Most probably, you don't have the entire
directory, and it should be installed from some locale package.

More information about the xorg mailing list