Xorg snapshots, and i915 driver

Alain Gagnon agagnon at oriso.com
Thu Mar 24 12:46:25 PST 2005


I've just gotten a laptop with an integrated i915GM chipset, and a WVGA
screen, native resolution of 1280x800. All pretty recent technologies,
but googling around, some people have managed to make it work, sadly, I
haven't so far.

>From what I gathered, support for the i915GM chipset will be added in
next version of Xorg, which should be 6.8.3. But binary snapshots gotten
at http://dri.freedesktop.org/snapshots/ if you also have support for
the chipset in kernel 2.6.11. I run slackware, and compiled a working
version of the 2.6.11 kernel, now it's detected at boot, confirmed by
agpgart: Detected an Intel 915GM Chipset.

When using Xorg 6.8.2, and installing the dri snapshots, I am able to
use the i810 driver succesfully, but am stuck, at best, in 1024x768. I
tried following some advice about setting the vertical and horizontal
refresh, setting modelines, but nothing seems to work. After playing
around in the log file, I noticed something that's bugging me, and which
I think may be why I can't get a working 1280x800. Excerpts from
Xorg.0.log follows:

(II) I810: Driver for Intel Integrated Graphics Chipsets: i810,
        i810e, i815, i830M, 845G, 852GM/855GM, 865G, 915G, 915GM
(II) Primary Device is: PCI 00:02:0
(WW) I810: No matching Device section for instance (BusID PCI:0:2:1)
(--) Chipset 915GM found

So okay, I've got a working chipset detected, let's go on:

(II) I810(0): initializing int10
(WW) I810(0): Bad V_BIOS checksum
(II) I810(0): Primary V_BIOS segment is: 0xc000
(II) I810(0): VESA BIOS detected
(II) I810(0): VESA VBE Version 3.0
(II) I810(0): VESA VBE Total Mem: 7872 kB
(II) I810(0): VESA VBE OEM: Intel(r)915GM/910ML/915MS Graphics Chip
Accelerated VGA BIOS
(II) I810(0): VESA VBE OEM Software Rev: 1.0
(II) I810(0): VESA VBE OEM Vendor: Intel Corporation
(II) I810(0): VESA VBE OEM Product: Intel(r)915GM/910ML/915MS Graphics
(II) I810(0): VESA VBE OEM Product Rev: Hardware Version 0.0
(II) I810(0): Integrated Graphics Chipset: Intel(R) 915GM
(--) I810(0): Chipset: "915GM"

The Bad V_BIOS checksum warning is troubling me a bit, but I have no
clue what impact it could have. The rest seems okay.

Mode: 30 (640x480)
        ModeAttributes: 0x9b
        WinAAttributes: 0x7
        WinBAttributes: 0x0
        WinGranularity: 64
        WinSize: 64
.. (cut for readability)

Mode: 32 (800x600)
        ModeAttributes: 0x9b
        WinAAttributes: 0x7
        WinBAttributes: 0x0
        WinGranularity: 64
        WinSize: 64
.. (same...)

Mode: 34 (1024x768)
        ModeAttributes: 0x9b
        WinAAttributes: 0x7
        WinBAttributes: 0x0
        WinGranularity: 64
        WinSize: 64
Mode: 38 (0x0)
        ModeAttributes: 0x0
        WinAAttributes: 0x0
        WinBAttributes: 0x0
        WinGranularity: 0
        WinSize: 0

This is where it bugs me the most. It seems to have no modes aside from
those three. The rest are all 0x0 and repeats of the other 3 modes for
other supported depths, I assume.

(II) I810(0): Not using mode "1280x800" (no mode of this name)
(--) I810(0): Virtual size is 1024x768 (pitch 1024)
(**) I810(0):  Built-in mode "1024x768"
(**) I810(0):  Built-in mode "800x600"
(**) I810(0):  Built-in mode "640x480"
(==) I810(0): DPI set to (75, 75)

Seems to me the VGA BIOS does not have a mode 1280x800 and Xorg then
uses the next available one. 

My question is this, is this a problem with my bios? Will this be fixed
in the next release of Xorg? Or should I try and contact the
manufacturer of the laptop (which might be problematic, it being a
whitebook) for a bios update, or such? I don't know if this is the right
list to address, but it's the only one I found with technical help for
built-in drivers from dri, or xorg.

Thanks in advance for any help or guidance!

Alain Gagnon

More information about the xorg mailing list