[packagekit] backend 0.4.x and 0.5.x compatibility
Anders F Björklund
afb at algonet.se
Thu Aug 27 03:25:49 PDT 2009
Richard Hughes wrote:
>> Since PolicyKitOne isn't released, and maybe won't be available
>> for a long time since it requires (pre-release) glib >= 2.21.4,
> Sure it it -- it's had quite a few releases. Just because stuff
> depends on unstable releases of libraries, doesn't mean it's not been
> released. I was playing with it in Fedora 11 and now use it every day
> using F12 alpha.
I meant pre-release as in "WARNING WARNING WARNING: This is a prerelease
on the road to PolicyKit 1.0. Public API might change and certain parts
of the code still needs some security review. Use at your own risk."
But sure, it does have a few version numbers and tarballs already...
Says that is parallel-installable though, so it's mostly about glib21.
(found details on https://fedoraproject.org/wiki/Features/PolicyKitOne)
>> would it be a good idea to have backends support both versions ?
>> (support both of PackageKit 0.4.x and PackageKit 0.5.x that is)
> I still support 0.4.x and 0.5.x, but 0.4.x is is feature freeze and
> bug-fix only mode. 0.5.x is where all the cool new stuff happens.
> 0.4.x will be deprecated when 0.6.0 is released.
Maybe better to try to get 0.5.x to run then, instead of backporting
the backends to the 0.4.x branch. (It's just polkit/devkit missing.)
>> Is there a list of changes between the API versions somewhere ?
> git diff PACKAGEKIT_0_4_X..master src/org.freedesktop.PackageKit*.xml
Thanks, very helpful! (had to use "origin/" if not local branch)
So it's mostly about the only_trusted and the Simulate API then.
>> (maybe one can still share the same spawned scripted backend...)
> I don't think that's a really good idea, I mean, the only_trusted
> stuff is very important in 0.5.x.
If your backend supports it, I guess. For instance the "smart" and
"ports" backends do not. (Lacking upstream/package manager support)
More information about the PackageKit