Activated service 'org.freedesktop.systemd1' failed

Дилян Палаузов dpa-freedesktop at
Mon Sep 10 19:50:11 UTC 2018


thanks for your anwers. suggests  
'XDG_SESSION_TYPE=wayland dbus-run-session gnome-session' for staring  
Gnome.  It worked for a while somehow, perhaps with an older systemd -  
some things were started, others not and I got then the "Activated  
service 'org.freedesktop.systemd1' failed" but more has worked.

How to start Gnome from a console with Wayland?

I use systemd with whanever happens to be default.  Does this imply  
systemctl --user?

My dbus 1.12.10 is set up with "./configure --prefix=/usr  
--sysconfdir=/etc --localstatedir=/var --enable-user-session".  The  
latter prints "Building systemd support: yes".

How to verify I have a properly set up systemd-logind session?

After login and starting weston and epiphany I have these processes:

message+   654     1  0  9772  3648   0 Sep04 ?        00:00:53  
/usr/bin/dbus-daemon --system --address=systemd: --nofork --nopidfile  
--systemd-activation --syslog-only
d        21278 21262  0  9265  3956   2 19:42 ?        00:00:00  
/usr/bin/dbus-daemon --session --address=systemd: --nofork --nopidfile  
--systemd-activation --syslog-only
d        21343 21338  0  9177  3156   2 19:43 ?        00:00:00  
--nofork --print-address 3

so a session bus is running.

----- Message from Lennart Poettering <mzqohf at> ---------
     Date: Mon, 10 Sep 2018 20:52:43 +0200
     From: Lennart Poettering <mzqohf at>
Subject: Re: Activated service 'org.freedesktop.systemd1' failed
       To: Дилян Палаузов <dpa-freedesktop at>
       Cc: dbus at

> On Mo, 10.09.18 18:20, Дилян Палаузов (dpa-freedesktop at wrote:
>> Hello,
>> when I enter 'XDG_SESSION_TYPE=wayland dbus-run-session gnome-session' I see
>> the messages below.  My feeling is than nobody ever tried to start service
>> org.freedesktop.systemd1 but a missing service … is missing.  How can I find
>> out the cause for the error messages below?  I use dbus 1.12.8.
> In a systemd world there's only a per-user systemd instance, but no
> per-session systemd instance. You appear to start a new dbus session
> instance though on top of the one you already have. On that new
> session systemd won't be around of course, as it is not supported.
> Or in other words, sorry, but per-session dbus is not supported on
> systemd systems anymore. There can only be a single dbus bus per user
> on systemd systems and systemd already starts that for you.
> Lennart
> --
> Lennart Poettering, Red Hat

----- End message from Lennart Poettering <mzqohf at> -----

More information about the dbus mailing list