[Fontconfig] Fontconfig 2.10.0 mingw build broken

Damon Register dregister at clear.net
Sat Jul 21 11:21:20 PDT 2012

On 7/21/2012 12:41 PM, Mike Frysinger wrote:
> On Saturday 21 July 2012 12:17:29 Damon Register wrote:
>> I was able to build fontconfig 2.9.0 using mingw without any trouble.  I
>> saw that 2.10.0 was released so I tried that.  configure seems to complete
>> without any problem.  When I run make, it seems to want to do config all
>> over again. make output starts like this:
>> CDPATH="${ZSH_VERSION+.}:" && cd . && /bin/sh
>> /d/gtki2/fontconfig-2.10.0/missing --run aclocal-1.11
> your timestamps are messed up -- autotools should not be automatically
> regenerated.  any errors after this point are irrelevant.
Well this is embarrassing.  As soon as you mentioned timestamps, I think I
know what the problem is.  I rebuilt tar (because I wanted a newer version).
I did tar xvf fontconfig-2.10.0.tar and did a directory compare between the
newly unpacked fontconfig and a previous one (as a test to see if the new tar
mangled any of the files).  All files were a binary match but the timestamps
were different.  I will toss the new tar, wipe my gtk3 build folder and
start over.  since I have a slow computer, maybe tomorrow I will let you know
how it turned out.  Thanks for your help.

Damon Register

More information about the Fontconfig mailing list