[gst-devel] Re: "No such element or plugin mad"

Mark Dezelon markdezelonti at yahoo.com
Fri Dec 17 02:14:03 CET 2004

vishwanath H.G wrote:
> 5. Run "gst-register" on target
> # gst-register
> Rebuilding global_registry
> (/usr/local/fs/vishwa/var/cache/gstreamer-0.8/registry.xml) ...
> Rebuilding user_registry (/root/.gstreamer-0.8/registry.xml) ...
> Loaded 0 plugins with 0 features.

I concur with everything Thomas wrote.

Also, if gst-register is loading zero plugins, then you
should fix that problem before moving on to the mad plugin.
I'm also compiling GStreamer for the ARM, and I've just
gotten it to compile and execute.

I ran "gst-register --gst-debug-level=5" to verify that it
found the normal plugins.  In my case, the plugins were
found, but each plugin wasn't recognized as a GStreamer
plugin. To make a long story short, when I compiled glib for
the arm, I supplied "glib_cv_uscore=yes" in the autogen
file; turns out I really wanted "glib_cv_uscore=no". After
reconfiguring and recompiling glib, GStreamer worked as

Other pages that helped me:

* glib-2.4.8/docs/reference/glib/html/glib-cross-compiling.html (from
within glib)

Once "gst-register" loads plugins and "gst-inspect fakesrc"
returns expected information, then you can focus on loading
the mad plugin.

Just some thoughts; hope that helps.

-- Mark Dezelon

Do you Yahoo!? 
Meet the all-new My Yahoo! - Try it today! 

More information about the gstreamer-devel mailing list