[gst-devel] Problems displaying an avi file

Phil Fisher phil.fisher at eu.citrix.com
Thu May 12 07:07:58 CEST 2005

I'm fairly new to gstreamer, so if there is a better place to ask the
question or some documentation that I should read please let me know and
accept my apologies.

I'm using the SuSe 9.3 distrubution (gstreamer-0.8.9-5 with 0.8.8-13
versions of plugins, plugins-extra, plugins-excess and plugins-default)

When I run:
% gst-launch videotestsrc ! xvimagesink
A windows appears with colour bars and a changing snowstorm effect in
the bottom right hand corner. I've assumed this is the correct

When I run:
	% gst-launch sinesrc ! osssink
I hear the expected tone.

When I try to run an avi file I get:
	% gst-launch-ext-0.8 60sMpeg42.avi 
No configuration file /home/phil/.gst found.  You might want to create
This is not an error, just a friendly reminder... Check the man page.

Running command-line
gst-launch-0.8 filesrc location="60sMpeg42.avi" ! decodebin name=d { d.
! queue ! ffmpegcolorspace ! xvimagesink } { d. ! queue ! audioconvert !
audioscale ! osssink }

RUNNING pipeline ...

However, no window appears for the video output and there is no sound

As the filename suggests it has mpeg 4.2 data in an avi format.

I tried running the generated gst-launch command by hand setting a
-gst-debug-level, but I didn't see any obvious problem.

I'd be grateful for any suggestions for investigating this.



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/gstreamer-devel/attachments/20050512/b6d1674f/attachment.htm>

More information about the gstreamer-devel mailing list