[gst-devel] AC3 audio on gstreamer + rtp

Sergio Belmar Argudo belmar_argudo at yahoo.es
Thu Dec 18 11:22:58 CET 2008

I'm trying to send audio form a mp3 file with gstreamer encoded with faac on RTP.

The problem is that I can't play it with any player (I like to play it with mplayer, vlc, etc. using a SDP file)

I'd tested it with a mp3 file and the following command:

gst-launch-0.10 -v filesrc location=/share/sample.mp3 ! flump3dec !
queue max-size-buffers=0 max-size-time=0 ! ffenc_libfaac ! queue
max-size-buffers=0 max-size-time=0 ! queue max-size-buffers=0
max-size-time=0 ! rtpmp4apay ! udpsink host= port=6060

and I have this SDP:


o=- 116704633 116704633 IN IP4


t=0 0



c=IN IP4

m=audio 6060 RTP/AVP 96

a=rtpmap:96 MP4A-LATM/48000/2

But there is no sound in mplayer or vlc.

I also tried faac and ffenc_libfaac to encoding, rptmpapay and rtpmpa4pay to packetise, MP4A-LATM and mpeg-generic in SDP file..., but nothing.

Has Anybody any idea?

Has Anybody tried anything like that?

Is it a problem only with audio encoding or SDP file config or is there a bug in any part?


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/gstreamer-devel/attachments/20081218/6b3d31b7/attachment.htm>

More information about the gstreamer-devel mailing list