[gst-devel] how to cleanly re-install gstreamer? Help!!

Yiliang Bao yiliangb at gmail.com
Wed Sep 2 08:41:30 CEST 2009


I compiled and installed the latest gst-rtsp-server, and updated gstreamer
itself based on the error messages from gst-rtsp-server installation.
However, after these steps, I could no longer find some plugins like mad,
xvimagesink, v4l2src, etc. 

I have tried re-installing the latest versions of all plugin packages. I
have also tried to remove, then re-install all plugins from Synaptic Package
Manager. Got some plugin, like v4l2src, back, but mad, xvimagesink are still
missing. autovideosink is there, but some pipleine which works is no longer
working. For example:

gst-launch v4l2src device=/dev/video0 ! autovideosink

>>>>>> Error messages:

Setting pipeline to PAUSED ...
ERROR: Pipeline doesn't want to pause.
ERROR: from element /GstPipeline:pipeline0/GstAutoVideoSink:autovideosink0:
Could not initialize supporting library.
Additional debug info:
gstautovideosink.c(373): gst_auto_video_sink_detect ():
Failed to set target pad
Setting pipeline to NULL ...
Freeing pipeline ...

gst-launch filesrc location=Videos/xyz.avi ! decodebin ! autovideosink

>>>>>>>>> Error messages:

Setting pipeline to PAUSED ...
Pipeline is PREROLLING ...
ERROR: from element
Internal data stream error.
Additional debug info:
gstavidemux.c(4443): gst_avi_demux_loop ():
streaming stopped, reason not-linked
ERROR: pipeline doesn't want to preroll.
Setting pipeline to NULL ...
Freeing pipeline ...

Does anyone know why? Is it possible to re-install a clean version of

View this message in context: http://www.nabble.com/how-to-cleanly-re-install-gstreamer--Help%21%21-tp25252421p25252421.html
Sent from the GStreamer-devel mailing list archive at Nabble.com.

More information about the gstreamer-devel mailing list