record issue sound very low

mattes effemm at
Sun Dec 23 23:33:00 PST 2012

You are using different sound system in both recordings, even though both
might use the same 

 phsyical device, ther eis a difference between pulse and alsa. 

 try to adjust the alsasrc capture volume, you can use alsamixer for that. 

 select F6 to select your sound device, then F4 for the capture settings 


 On Sun, 23 Dec 2012 20:55:41 +0100 Claude Vittoria wrote

  Hi! I m discovering gstreamer to record audio and I got an issue. I m
looking for an explication.
 I tried a test
 gst-launch -e pulsesrc
device="alsa_input.usb-Samson_Technologies_Samson_UB1-00-UB1.analog-stereo" !
audioconvert ! audioresample ! pulsesink
 and it works very well, good sound in the headphone
  gst-launch -e alsasrc
device="alsa_input.usb-Samson_Technologies_Samson_UB1-00-UB1" ! queue !
audioconvert ! 
 ffenc_ac3 ! filesink location=audio.mp3
 the mp3 is not audible, the sound comes from far far far distance as the mic
was not amplified.
 I tried to modify the settings through the gnome sound applet, alsamixer,
pavucontrol without result
 What I do not understand in the pipeline concept ?
  I work with a debian sid.
  $gst-launch --version
 gst-launch-0.10 version 0.10.36
 GStreamer 0.10.36 [1]
   Thanks and Merry Christmas

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the gstreamer-devel mailing list