Custom plug in not registering (CentOS 5.7)

Jaime Gago jaime at
Mon Jan 9 21:53:56 PST 2012

Hi Nathanael thanks for your input, I didn't know about ldd but when ran against the .so there were no complaints about missing libs.
What about Linux distros? Could it be the plugin  is meant for an Ubuntu system therefore won't work as is on CentOS?

I don't know if this means anything to you, but here is the content of the that comes with binary after I build, there is a clear reference to Ubuntu.

# - a libtool library file
# Generated by (GNU libtool) 2.2.6b Debian-2.2.6b-2ubuntu1
# Please DO NOT delete this file!
# It is necessary for linking the library.

# The name that we can dlopen(3).

# Names of this library.

# The name of the static archive.

# Linker flags that can not go in dependency_libs.
inherited_linker_flags=' -pthread'

# Libraries that this one depends upon.
dependency_libs=' -L/lib64 -lgstbase-0.10 -lgstcontroller-0.10 -lgstreamer-0.10 -lgobject-2.0 -lgmodule-2.0 -ldl -lgthread-2.0 -lxml2 -lz -lglib-2.0'

# Names of additional weak libraries provided by this library

# Version information for libgstdecklink.

# Is this an already installed library?

# Should we warn about portability when linking against -modules?

# Files to dlopen/dlpreopen

# Directory that this library needs to be installed in:
On Jan 9, 2012, at 8:15 AM, Nathanael D. Noblet wrote:

> On 01/09/2012 01:26 AM, Jaime Gago wrote:
>> Hello there, happy new year all,
>> I'm trying to use a install a custom gstreamer plugin to deal with a Black Magic Intensity pro card but despite all my efforts I haven't been able to load it =[.
>> I'm able to configure, make, make install (or so it seems) and I get a .la and .so placed in /usr/lib/gstreamer-0.10 with the same permissions as the other plugins. When I run gst-inspect my_custom_plugin i get a "No such element or plugin 'my_custom_plugin'. I tried to delete ~/.gstreamer-0.10/registry.x86_64.bin and then run gst-inspect but still the custom plugin (i.e. decklinksrc) is not registering.
>> I'm running CentOS 5.7 but the plugin doc is meant for Ubuntu could it be I'm missing some libraries even though the plugin build _seems_ successful?
> If you want to check that, ldd can tell you what a binary and I assume shared library need to run, it will also show if it can't find required libs.
> The other bit I would be suspect about is whether the gstreamer plugin requires the device to be 'present' in some way that it is not on your system?
> Just random thoughts.
> -- 
> Nathanael d. Noblet
> t 403.875.4613
> _______________________________________________
> gstreamer-devel mailing list
> gstreamer-devel at

More information about the gstreamer-devel mailing list