Prerequisites needed for uvch264?

Adam Goodwin at
Sun Jul 21 08:51:50 PDT 2013

Thanks a lot, that's good to know about the memory issues with version 0.1x
because I was thinking of giving that a go tomorrow.

I'm not intending to cut the stream many times, so with a bit of luck using
version 0.1 will be a good solution. I'll probably continue trying to
install 1.1.2 for uvch264 as well though, just in case it ends up working -
I'll look into apt-cache's options.

Thanks again for the quick response

On Mon, Jul 22, 2013 at 3:12 AM, Peter Rennert <p.rennert at>wrote:

> At the moment it seems as uvch264src of Gstreamer1x does not work. It
> works, however for Gstreamer 0.1x therefore it might be advisable to go for
> that instead. For my project that relies on cuting the video stream
> precisely and saving it into several files. Unfortunately, I experienced
> memory issues in Gstreamer 0.1x.
> I am now stuck somehow, because in Gstreamer1 I can cut an h264 stream
> without problems but cannot use the camera, while in Gstreamer 0.10 I can
> use the camera but I have a memory leak and loss of data each time I cut
> the stream.
> I remember that I had the u_dev problem too when I tried to complile
> Gstreamer the first time a year ago. So I don't remember exactly what I did
> to solve it but I remember loosely that I ended up installing something
> else that shipped that header files. I don't know ubuntu, but i think
> apt-cache is supposed to be able to tell you which package provides a
> certain library you are looking for.
> Adam Goodwin < at> wrote:
>> Hi,
>> I'm working on a project where I need to get H264 encoded video from a
>> Logitech C920.
>> As I understand it I need to use uvch264 for this, as v4l2src is not able
>> to get H264 encoded video from a C920. (This is based on a few discussions
>> I've found online and the fact that a basic pipeline like "gst-launch-1.0
>> v4l2src ! video/x-h264 ! fakesink" doesn't work.)
>> The stable 1.0.8 release of gst-plugins-bad doesn't have uvch264 ported
>> yet, so I've tried to install the 1.1.2 developer release which does.
>> Unfortunately, this is what I get regarding uvch264 when I try to
>> "./configure" the bad plugins:
>> *configure: *** checking feature: UVC H264 ***
>> configure: *** for plug-ins: uvch264 ***
>> checking linux/uvcvideo.h usability... yes
>> checking linux/uvcvideo.h presence... yes
>> checking for linux/uvcvideo.h... yes
>> checking for GST_VIDEO... yes
>> checking for G_UDEV... no
>> checking for LIBUSB... no
>> configure: *** These plugins will not be built: uvch264
>> *I'm pretty new to all this GStreamer stuff, so excuse my ignorance, but
>> to try and resolve the missing "G_UDEV" and "LIBUSB" dependencies I
>> installed the following packages (I am using Ubuntu 13.04) with these
>> commands:
>> "sudo apt-get install libgudev1.0-cil-dev"
>> "sudo apt-get install libusb-dev"
>> But I get the same results, "checking for G_UDEV..." and "checking for
>> LIBUSB..." still both say "no".
>> Even worse, with this 1.1.2 build of GStreamer I can't use v4l2src to get
>> another video format from the camera. The "gst-inspect-1.0 -b" command
>> shows "" as blacklisted. So I'm giving up on this for
>> tonight.
>> ---
>> Basically, my question is this: Assuming there isn't some way of getting
>> v4l2src (from a stable release) to stream the H264 encoded video from my
>> C920, can anyone help me get the right dependencies so that uvch264 will
>> install?
>> ------------------------------
>> gstreamer-devel mailing list
>> gstreamer-devel at
> --
> Sent from my Android device with K-9 Mail. Please excuse my brevity.
> _______________________________________________
> gstreamer-devel mailing list
> gstreamer-devel at
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the gstreamer-devel mailing list