appsink not working with valve element

Julio jeloguin at
Tue Oct 6 13:48:39 PDT 2015

Hi guys.

I have a problem with appsink.

I have a pipeline like this:


My goal is receive samples in apsink only when valve element is not dropping

I configure valve element with drop=true before start the pipeline ....

Then, when desired, I configure valve element to drop=false, then I begin to
receive samples in appsink , and a few secons later I configure valve
element to drop=true.

My problem is, when I try to repeat the process, ( set valve drop=false,
receive samples, drop= true ), I receive in appsink the same sample last
time I have received !!. Seems that some samples are not freed in the chain
when I begin to drop buffers in the valve. But I have tried sending an eos
event to appsink, unlink it, set to null and link again ... with no luck
..., old samples remain in the chain when I begin to receive ...

Any idea about how to solve it ?.

The other option to obtain the same result is to create the second branch of
the tee dynamically, but with that option I get a big memory leak ... so
first option is my choice ...

Thanks a lot !!!


View this message in context:
Sent from the GStreamer-devel mailing list archive at

More information about the gstreamer-devel mailing list