tcpclientlink not linked

RAJensen RAJensen at
Sun Apr 3 06:20:43 UTC 2016

Hello G-Streamers

I'm totally new to mailing-lists, so don't where to put my script...
So i've put it on Pastebin and a link  here <> 

I hope someone can help med with this problem that i can't solve.
I have one Gst-pipeline running with a tcpserversink to a tcpclientsrc
running from command-line and it will work with this launch-cmd:
gst-launch-1.0 tcpclientsrc ! host= port=9001 ! gdpdepay !
rtph264depay ! h264parse ! decodebin ! videoconvert ! autovideosink

Video caps are being set at serverside.

I have then tried to make that lanch into a Python-script.

But for some reason that i can't figure out, when the script is executet
i'll get Gst-masssage: /GstPipeline:player/GstTCPClientSrc:tcpclientsrc_1:
streaming task paused, reason not-linked (-1)

If server is not running, as expectet: error for not being allowed acces.
 Do tcpclientsrc need som kind of caps reader, to get caps from stream and
that's why is not linked...?
I ahve also tried with:
So can anyone help me pointing at where or what link did i miss..?

I have being all over dev-doc, tutorials, google and moore, but i can't see
what i've missed
Also script is very simpel, so i.e. I haven't made do-timestamp and so on.
But serverside is startet by command launch and have all the Caps, depay
config and so on.

In advance: thank for your help. 

Python-script on pastebin <>  

View this message in context:
Sent from the GStreamer-devel mailing list archive at

More information about the gstreamer-devel mailing list