Best way to get at least 1.14.2 on Raspberry Pi?

Vincenzo Bono vincenzo.bono at
Wed Sep 5 14:02:56 UTC 2018

I was trying to do the same as 2) below in July, and submitted some patch in the process (search for "Bono" in this ML to find some reference).

My remaining problem on Raspberry Pi was that libgstsoundtouch, libgstvoaacenc and libgstdtls didn't seem to be built... I was looking at recipes and didn't find yet anything helpful at that time.

These libraries were missing, and I didn't have more time to investigate.

I tried to build on Raspian x86, and the latest Ubuntu LTS, just to check if those libraries are built, but got stuck in other issues (submitting a couple of patches as well). The remaining one is that Raspian x86 is detected (correctly) as 64 bit, but have the libraries in 32 bit. I started into cross-compiling to 32 bit, avoiding the 64 bit detection, but the compilation didn't proceed smoothly as I was hoping.

I was not looking into creating a full .deb for the Raspian ARM, just to build a local working environment... maybe we could team up in finding and fixing the small issues there, submitting patches (?


Il giorno 05/09/18, 14:47 "gstreamer-devel per conto di Dominik Röttsches" <gstreamer-devel-bounces at per conto di d-r at> ha scritto:

    I am working on a WebRTC experiment on a Raspberry Pi using the 
    gstreamer Python bindings. Since there is a bug in gstreamer versions 
    before 1.14.2 that causes a double free when using the full 
    PeerConnection like webrtc flow in Python, I need at least this version.
    However, the gstreamer version on Debian stretch is 1.10.2 - way too 
    Things I've tried:
    1) Looking at Deb Multimedia packages, but it doesn't have 1.14.2 for 
    Debian stretch.
    2) I tried running the cerbero build on the Raspberry itself, which is 
    very slow and I kept running into small build failures. Working around 
    each of those and restrating the $ cerbero package gstreamer-1.0 has not 
    gotten me there yet.
    3) I tried an armhf cross compilation on an X86 Ubuntu 18.04 system, 
    which perhaps builds but does not succeed in packaging .deb files that I 
    can use on the RPI.
    4) I am now working on a docker image using the resin 
    raspberrypi:stretch image and run the cross compilation "natively" 
    inside that image using their qemu-based emulation approach using RUN 
    ) - this is a bit better in terms of build performance, and it gets 
    relatively far but I still have some build failures using cerbero, that 
    I am still working around (for example, even though I have install 
    libx11-dev the cebero build complains it can't find the x11 dependency, 
    similar for OpenGL). I have now added "nogl" and "nox11" to the cerbero 
    variants and I am observing the next build. The roundtrip time here is 
    very long as well.
    What would you suggest to get a recent, i.e. at least 1.14.2, binary on 
    the Raspberry Pi?
    Thank you very much for your suggestions,
    gstreamer-devel mailing list
    gstreamer-devel at

More information about the gstreamer-devel mailing list