Using nlecomposition and nlesource

amindfv at amindfv at
Wed Dec 14 08:26:56 UTC 2022

On Tue, Dec 13, 2022 at 05:41:18PM +0200, pecisk--- via gstreamer-devel wrote:
> Hi!
> I am trying to do some nonlinear stuff and trying to use NLE elements from
> GES. I have nlecomposition, which contains nlesource, which in turn
> contains nleurisource. However, every time try to put pipeline into playing
> state, I get this:
> ERROR         nlecomposition
> nlecomposition.c:1812:_seek_current_stack:<composition> Can't seek because
> no pad available - no children in the composition ready to be used, the
> duration is 0, or not committed yet

Just a guess, maybe "or not committed yet" is what's missing?


> I tried to use audio test source added to nlesource, and I got same issue
> as well. When I have just nlesource added to composition, it doesn't
> trigger error, but obviously it doesn't have anything to play.
> Poking at logs *:5 it looks like nlesource has issues connecting pads with
> child - it tried to connect to sink for audio test source, which did not
> make sense.
> Any suggestions and hints would be appreciated :)
> Peter.

More information about the gstreamer-devel mailing list