can not find webrtcdsp and webrtcechoprobe for windows

养猪小户 7293383 at
Thu Feb 16 09:29:04 UTC 2023

Thank you Nicolas! I tried to include these 2 plugins in gst by my own, but failed. First I tried to "meson -Dwebrtcdsp=enabled build" to enable it, but it turns out missing dependency of webrtc-audio-processing. Then I tried meson build under gst-build\subprojects\webrtc-audio-processing, but it failed in "ninja -C build". It is first time I build gst, anyone can give a guide on how to build webrtcdsp and webrtcechoprobe with msvc?

Many thanks.

------------------ Original ------------------
From:                                                                                                                        "Nicolas Dufresne"                                                                                    <nicolas at>;
Date: Sat, Jan 28, 2023 08:38 PM
To: "Discussion of the development of and with GStreamer"<gstreamer-devel at>;
Cc: "养猪小户"<7293383 at>;
Subject: Re: can not find webrtcdsp and webrtcechoprobe for windows

Le sam. 28 janv. 2023, 06 h 30, 养猪小户 via gstreamer-devel <gstreamer-devel at> a écrit :

Hi all,
I installed gstreamer-1.0-msvc-x86_64-1.22.0.msi and gstreamer-1.0-devel-msvc-x86_64-1.22.0.msi both for complete mode. But in gst-inspect-1.0.exe I still cannot find webrtcdsp and webrtcechoprobe. Some other plugins in bad plugins can be found, what should I do to install these 2 plugins?

I believe there was build issue of that in msvc (path too long?), So it has been disabled, someone should probably give that a look again, I was told meson have had some improvement for these cases.

Meanwhile, it should be available in the mingw builds for your convenience.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the gstreamer-devel mailing list