USB key troubles

Vlaaad vlaaad at
Mon Oct 3 16:31:33 PDT 2005

Hello people !

I'm trying to get gnome-volume-manager 1.5.1 working fully for the
distro I contribute to (Source Mage). All seems to work except some
troubles with USB keys and I think hald is guilty, or at least it is not
well configured on my box. I spent hours and hours and I didn't manage
to solve it, I so request some help if someone has some extra free

I use hal 0.5.4, udev 070, hotplug 2004_09_23 and dbus 0.35.2. I also
tried hotplug-ng 002 just in case, but that didn't changed anything.

The problem I identified is when I put my USB key (I also tried with
another one) and that hald is launched, it is not recognized and not
listed with lshal. If I put my USB key and then I launch hal, it is well
recognized, listed in lshal and so mounted by gvm.
Udevd is well running, udevstart has been launched, udevsend has been
setup as the hotplug multiplexer. /dev/sdb and /dev/sdb1 are well
created and removed when I plug/unplug the key.

I tried to launch hal in debug mode. 

First case, usk key plugged, hald launched right after. My USB key is
well listed in lshal and can be even mounted with pmount-hal. I didn't
mounted it. I just wait some time and remove it. I get dozens of :

24668: 00:14:18.129: addon-storage.c:282: open failed for /dev/sdb: No
such file or directory

It is still in lshal during this time. The error messages stop when I
put back the usb key.

Second case now. I remove the key. I kill hald. I launch hald. I put the
key. Hald tells me :

        00:17:16.313 [I] osspec.c:243: total_read=225
        00:17:16.324 [I] osspec.c:243: total_read=1024
        00:17:16.659 [I] osspec.c:243: total_read=178
        00:17:16.661 [I] osspec.c:243: total_read=311
        00:17:17.159 [I] osspec.c:243: total_read=837
        00:17:17.390 [I] osspec.c:243: total_read=491
        00:17:17.402 [I] osspec.c:243: total_read=177
        00:17:22.405 [I] osspec.c:243: total_read=234
        00:17:22.454 [I] osspec.c:243: total_read=219
        00:17:22.504 [I] osspec.c:243: total_read=469

(I have a webcam on the same usb hub). But nothing appears in lshal |
grep sdb ! Quite annoying... :/ After removing the USB device, hald

00:24:53.299 [I] osspec.c:243: total_read=1024
00:24:53.412 [I] osspec.c:243: total_read=166

I wonder what I could have made wrong... 

Here some more informations :

[01:08:34]root at Gargamel /home/vlad # ll /etc/hotplug.d/default
total 4
lrwxrwxrwx  1 root root   14 2005-09-11 16:40 10-udev.hotplug
-> /sbin/udevsend
lrwxrwxrwx  1 root root   24 2005-10-01 13:54 20-hal.hotplug
-> /usr/libexec/hal.hotplug
-rwxr-xr-x  1 root root 2931 2005-09-09 19:40 default.hotplug

[01:11:16]root at Gargamel /home/vlad # more /proc/sys/kernel/hotplug

I noticed there used to be a /etc/dev.d/default/ with hal 0.4,
but this has been removed in 0.5, right ? Was it not to notify hal about
udev events ? Is there something similar in 0.5 that I could miss ?

I will greatly appreciate any help, thanks a lot in advance. :-)
-- -- -- -- -- -- --
Flavien Bridault
Source Mage GNU/Linux - Disk Section Guru

irc: vlaaad
jabber: vlaaad at

More information about the hal mailing list