[Bug 101408] [BDW] Xonotic fails to render one of the weapons

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Tue Jun 13 18:45:53 UTC 2017


            Bug ID: 101408
           Summary: [BDW] Xonotic fails to render one of the weapons
           Product: Mesa
           Version: git
          Hardware: Other
                OS: All
            Status: NEW
          Severity: normal
          Priority: medium
         Component: Drivers/DRI/i965
          Assignee: intel-3d-bugs at lists.freedesktop.org
          Reporter: idr at freedesktop.org
        QA Contact: intel-3d-bugs at lists.freedesktop.org

Created attachment 131929
  --> https://bugs.freedesktop.org/attachment.cgi?id=131929&action=edit
Gun missing on BDW

One of the guns in Xontic does not render correctly on BDW.  However, the same
gun does render correctly on BYT.  At Ken's suggestion, I tried
INTEL_SCALAR_VS=0, but that did not help.

With some additional modifications to the driver, I can add '+r_glsl_skeletal
1' to the Xonotic command line.  This causes Xonotic to use a different
animation system that uses UBOs.  In this scenario, the gun is rendered

I have also tried back as far as Mesa 13.0.0, and the bug still existed there. 
I will try older versions.

I have not tried hardware other than BDW and BYT.

You are receiving this mail because:
You are the QA Contact for the bug.
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.freedesktop.org/archives/intel-3d-bugs/attachments/20170613/fbe7d9a0/attachment.html>

More information about the intel-3d-bugs mailing list