[Bug 107058] [Wayland] plasmashell gets SIGSEGV after clicking on Application Menu for second time

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Tue Nov 6 01:24:42 UTC 2018


--- Comment #19 from magiblot <magiblot at hotmail.com> ---
Created attachment 142379
  --> https://bugs.freedesktop.org/attachment.cgi?id=142379&action=edit
debug log having applied the patch above

(In reply to Danylo from comment #18)

It was very kind of you to provide a specific PKGBUILD for this purpose. It
indeed compiled much faster than I expected.

I was able to test the crash again, but got different results. I have been
unable to catch plasmashell getting SIGSEGV. It is just Xwayland who gets
SIGABRT twice and then exits.

I have already seen this before (not back when I opened this report) but
plasmashell would at times still get SIGSEGV. This doesn't seem to be the case

Some time ago I found the crash this report is about can be worked around with
'QT_QPA_PLATFORM=wayland-egl', which will force all Qt applications into native
Wayland rendering (and I guess plasmashell is one of them). So Xwayland can be
considered suspect of this issue.

If there is a bug in Qt, Xwayland or another library, then I imagine the
SIGSEGV was caused by either of these messing up before mesa finished rendering
their items (and thus causing the miptree not to be created properly). I guess
your patches just make mesa less vulnerable against this.

I'm enclosing the log for one of the crashes, with INTEL_DEBUG=fbo,mip. I have
no actual knowledge about rendering, so maybe you find more meaning in it.

Thank you very much.

You are receiving this mail because:
You are the QA Contact for the bug.
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.freedesktop.org/archives/intel-3d-bugs/attachments/20181106/319dfe48/attachment-0001.html>

More information about the intel-3d-bugs mailing list