[Libdlo] Multiscreen troubles with displaylink and intel

Frank Blendinger fb at intoxicatedmind.net
Fri Oct 9 05:35:20 PDT 2009

Hi Bernie.

On Thu 2009-10-08 08:49, Bernie Thompson <bernie at berniethompson.com>
> My testing has been nearly all with multiseat, so I'm ignorant of many of
> the Xinerama and Xrandr ins and outs of getting extended desktop working.
>  So I may get this wrong, but some of the potential causes:
> * Because xorg doesn't have multiadapter support yet -- without Xinerama on,
> the displaylink and intel drivers can't coexist in the same layout, which
> may be the cause of the unload.  Anyone know another way in which they
> could?

Alright, so I guess I tried to do something that was just not possible.

> * Probably don't want to have a SubSection "display" today for any
> displaylink device if you're using the monitor's preferred mode, as
> displaylink-mod gets the best timings from EDID, there are no Depth options,
> and 24bpp may cause a problem (seemed like removing that solved a problem
> recently - mentioned on this list)

You are right, that section was not necessary at all. My "dlonly" layout
works fine without it.

> * The current displaylink framebuffer driver is 16bpp (and may want to stay
> that way for performance/simplicity reasons). Xinerama requires all screens
> to be at the same color depth.
> [...]
> I'd try setting the Intel/TV to 16bpp and turn Xinerama on, and see if that
> works.

I tried it with Xinerama turned on and this "Screen" section for my TV:

    Section "Screen"
            Identifier      "scr-tv"
            Device          "dev-intel"
            Monitor         "mon-tv"
            DefaultDepth    16
            SubSection "Display"
                Depth       16
                Modes       "720x576 at 60.00"

This puts my intel TV screen into 16bpp mode, as Xorg.log shows:

    (**) intel(0): Depth 16, (--) framebuffer bpp 16

But the displaylink module still gets unloaded:

    (WW) intel(0): Register 0x61110 (PORT_HOTPLUG_EN) changed from 0x00000000 to 0x00000020
    (II) UnloadModule: "displaylink"
    (II) Unloading /usr/local/lib/xorg/modules/drivers//displaylink_drv.so
    (II) UnloadModule: "fbdevhw"
    (II) Unloading /usr/lib/xorg/modules/linux//libfbdevhw.so

And finally leads to X crashing with this:

    0: /usr/bin/X11/X(xorg_backtrace+0x26) [0x4ee026]
    1: /usr/bin/X11/X(xf86SigHandler+0x39) [0x4836c9]
    2: /lib/libc.so.6 [0x7f95824e8db0]
    3: /usr/bin/X11/X(RRCrtcGammaSet+0x1e) [0x51820e]
    4: /usr/lib/xorg/modules/drivers//intel_drv.so [0x7f9580ce8f63]
    5: /usr/bin/X11/X [0x489eb3]
    6: /usr/bin/X11/X [0x489fe8]
    7: /usr/bin/X11/X(xf86HandleColormaps+0x281) [0x48afc1]
    8: /usr/lib/xorg/modules/drivers//intel_drv.so [0x7f9580ced75f]
    9: /usr/bin/X11/X(AddScreen+0x1c6) [0x432ac6]
    10: /usr/bin/X11/X(InitOutput+0x241) [0x46d361]
    11: /usr/bin/X11/X(main+0x200) [0x4331d0]
    12: /lib/libc.so.6(__libc_start_main+0xe6) [0x7f95824d55c6]
    13: /usr/bin/X11/X [0x432819]

    Fatal server error:
    Caught signal 11.  Server aborting

Any ideas what else I could try? A patched intel driver was mentioned
some time ago on this list. Could that help maybe?

Or will I finally have to go the multiseat way? I have not yet tried
that, as it seems overly complicated for my use case - I just want the
displaylink as a dumb additional screen which can show some infos like
currently playing song etc. without the need to turn on my TV.


Frank Blendinger | fb(at)intoxicatedmind.net | GPG: 0x0BF2FE7A
Fingerprint: BB64 F2B8 DFD8 BF90 0F2E 892B 72CF 7A41 0BF2 FE7A
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: Digital signature
Url : http://lists.freedesktop.org/archives/libdlo/attachments/20091009/f7760129/attachment.pgp 

More information about the Libdlo mailing list