EM7455 on Lenovo Thinkpad T460s

Killian Keller keller.killian at gmail.com
Tue Mar 28 10:39:12 UTC 2017

Thank you very much for the fast help! I installed the 4.10 kernel and the
versions of libqmi and libmbim suggested by Tim. (the installation points at the correct library). The fcc-authentication
however, throws an error:

sudo qmicli -d /dev/cdc-wdm1 --device-open-mbim --dms-set-fcc-authentication
error: couldn't set FCC authentication: QMI protocol error (26): 'NoEffect'

Honestly, I have no Idea what this means. However, I set the
fcc-authentication way earlier (a week ago, I purged the installation of
modemmanager, libqmi and libmbim twice since then).

Thank you again so much for your time, I can't even tell you how much I am
thankful for your help!

On 27.03.2017 11:10, Killian Keller wrote:
> Hi guys,
> Did you manage to successfully create a connection with the EM7455? I 
> read through the mailing list, tried most of the suggestions, but 
> nothing seems to work for me. Could you point me in the correct 
> direction? I have been trying to get it to work for the last two weeks 
> (and it even worked for half an hour, with an Live-USB of Ubuntu) but 
> I do not get any progress.
> I work on a Lenovo Thinkpad T460s, the wwan module is a Sierra 
> Wireless EM7455. The operating system is Ubuntu 16.04, kernel is 
> 4.8.0-43-lowlatency. ModemManager version 1.6.0, qmicli 1.12.6, 
> mbimcli 1.14.0. No special branches used.
> Thank you very much for your time!
> Regards,
> Killian

More information about the libmbim-devel mailing list