[Libreoffice] curiosity in OResultSet.cxx

Terrence Enger tenger at iseries-guru.com
Sat Aug 6 11:01:54 PDT 2011

On Fri, 2011-08-05 at 16:03 +0100, Caolán McNamara wrote:
> On Fri, 2011-07-29 at 17:00 +0100, Caolán McNamara wrote:
> > (snip)
> > nah, the delete in OResultSet::setFetchSize is just bogus IMO and should
> > be delete[]. Your discovery, send in the obvious patch for glory.
> Fair enough, patched it myself :-)

Thank you.  

I have not been been ignoring you just for the sake of
ignoring you; rather I was keeping quiet while I collected
my questions.  Along the way I experienced some challenges
with ODBC driver installation, challenges which have nothing
particular to do with LibreOffice.  I also got a failure
from a query that works in LibreOffice as supplied in the
ubuntu-natty distribution; I shall start a separate thread
about that one.  Being a complete newbie with git, I also
screwed up my repository as I tried to generate the patch
file; this is merely another PEBCAK.

Do you know what I might be able to do to make LibreOffice
execute the line in question?  The queries I tried did not
execute the line, and I confess that I did not persist very
long exploring in opengrok.

As for the glory ...  I have an interest in bug 34309 "error
on importing a timestamp field from db2 via ODBC"
<https://bugs.freedesktop.org/show_bug.cgi?id=34309>.  That
is of course why I went poking into OResultSet.cxx.  If I
can contribute to the solution of that bug, I shall feel
that I have earned a wee bit of glory.


More information about the LibreOffice mailing list