[Libreoffice] Debugging crash in 3.3.2 on Mac OS X 10.6.6 - [SOLVED}

Peter Teeson peter.teeson at bell.net
Mon May 9 08:25:03 PDT 2011

Hi Michael:
On 2011-05-09, at 5:04 AM, Michael Meeks wrote:
> Hi Peter,
> On Sat, 2011-05-07 at 16:14 -0400, Peter Teeson wrote:
> 	Right - so, we think this is font related; so presumably you have some
> fun fonts on one system, but not another. Hopefully this re-assures you
> that this is a somewhat less widespread problem (?) :-)
>> So I hypothesize my regular system is foobar in some way that kills LO
>> 3.2.2.
> 	I suspect just some magic font oddness.

It was indeed!!
I compared the regular OS X 10.6 Fonts directory with the clean one andthey were identical.
Then I looked at ~/libray/Fonts and lo and behold there was a FreeSans.ttf one on the regular system 
and not on the clean one.
Removing that font made everything work correctly!

All of this done without having to go through the torture of gdb on the command line <grin>

As an experiment I put the font back into ~/Library/Fonts and launched LO
The opened a new Text document. When I scrolled up through the Font menu
from the Times item LO crashed the same way!!

Apple's Font Book application has a File/Validate File... item so I tried it with the offending font.
It told me that there was something wrong with it. Here is a tiff from Capture.

Now that we know the exact cause of the problem, and since it happens on 3.4 as well
and in at least Calc and Writer where do we go from here?


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/libreoffice/attachments/20110509/4b1f65e2/attachment-0001.htm>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: Bad Font.tiff
Type: image/tiff
Size: 58624 bytes
Desc: not available
URL: <http://lists.freedesktop.org/archives/libreoffice/attachments/20110509/4b1f65e2/attachment-0001.tiff>

More information about the LibreOffice mailing list