[API] Some more cleanup ideas

Stephan Bergmann sbergman at redhat.com
Mon Dec 3 01:49:34 PST 2012

On 12/03/2012 10:32 AM, Jan Holesovsky wrote:
>>>> using namespace com::sun::star would save some 5 additional
>>>> characters - let me see what a test build yields...
>>> ...but would increase potential for ambiguities.
>> Yes, so I went for the css alias in the end. This change has been
>> pushed to master.
> Please _please_ PLEASE name it "api" as you proposed first, not "css" -
> it nearly killed me when I found out what that means when I started with
> OOo [that it is not "cascade style sheet", but "com::sun::star"] - think
> of the newcomers ;-)

Given that the un-abbreviated "com.sun.star" will still appear in many 
places (Basic, Java, Python, UNOIDL source; instantiation of old-style 
services and singletons; implementation of services and singletons; 
...), I strongly suggest to use "css" rather than anything like "api."


More information about the LibreOffice mailing list