[PUSHED] adding calc add-in for option pricing

tino ttk448 at gmail.com
Tue Dec 4 09:40:55 PST 2012

> > Do I also have to change the function name exported to the cell, e.g.
> 	My concern here would be that potentially calc function naming is not
> always a great match to UNO constraints - and yet those functions are
> defined as IDL. Some functions have '.'s in them IIRC, others might want
> to have _'s (?) and translating functions is prolly not feasible via the
> UNO interface.

Not sure I understand, would you prefer to see no '_' and rather
me to change OPT_BARRIER() to OPTBARRIER() or something?

I've attached a patch to sort out the internal UNO variable/function
naming issue.

Cheers, Tino
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 0001-changed-function-names-and-variables-to-conform-with.patch
Type: text/x-patch
Size: 13058 bytes
Desc: not available
URL: <http://lists.freedesktop.org/archives/libreoffice/attachments/20121204/c347ac10/attachment-0001.bin>

More information about the LibreOffice mailing list