4.3.x linux packages and collada support

Zolnai Tamás zolnaitamas2000 at gmail.com
Sun Sep 28 02:46:34 PDT 2014

2014-09-27 20:57 GMT+02:00 Michael Stahl <mstahl at redhat.com>:

> On 27/09/14 16:05, Zolnai Tamás wrote:
> > 2014-09-27 15:23 GMT+02:00 Miklos Vajna <vmiklos at collabora.co.uk
> > <mailto:vmiklos at collabora.co.uk>>:
> >
> >     On Sat, Sep 27, 2014 at 08:26:38AM +0200, Zolnai Tamás
> >     <zolnaitamas2000 at gmail.com <mailto:zolnaitamas2000 at gmail.com>>
> wrote:
> >     > So the only question is:
> >     > Is it possible to replace the 4.3.1 and 4.3.2 linux packages with
> new ones
> >     > which are compiled with newer compilers? (expecting this is the
> problem)
> >     > To fix the bug mentioned above.
> >
> >     Isn't it possible to stick to boost::shared_ptr on -4-3, given that's
> >     what other code does?
> >
> >
> > It's the collada2gltf code which uses std::shared_ptr at many places so
> > it would be much work to replace all of them with boost::shared_ptr, but
> > actually can be done if necessary. I just thought packages are created
> > with newer compilers, since they generate more better output (in theory).
> > Other thing is that I need to know whether this is the problem indeed.
> > So can I know what compilers are used for packages? Are they support
> > std::shared_ptr?
> for LO 4.3 and earlier releases the RHEL5 gcc is used, i don't remember
> if it is gcc 4.1 or 4.4; we're only switching to a C++11 compiler for LO
> 4.4.
> actually most users will use the distro provided LO packages anyway and
> those don't suffer from our ancient upstream RHEL5 baseline.
> anyway, std::shared_ptr and boost::shared_ptr should be mostly the same,
> so "find ... | xargs sed -i ..." should be able to fix things up quite
> quickly to get a patch for the 4.3 branch.

I tried it an it came out there are other C++11 stuff in the code. I tried
to replace them, but the compiler does not help me with finding C++11 code.
When I compile with --std=c++03 flag, compiler just write out:
error: #error This file requires compiler and library support for the ISO
C++ 2011 standard. This support is currently experimental, and must be
enabled with the -std=c++11 or -std=gnu++11 compiler options.
Is there any option to avoid this general error and force the compiler to
try the older standard.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/libreoffice/attachments/20140928/9fe75d49/attachment.html>

More information about the LibreOffice mailing list