minutes of ESC call ...

Xisco Fauli xiscofauli at libreoffice.org
Tue Sep 20 08:53:58 UTC 2016

Hello Jan,

El 20/09/16 a les 10:30, Jan Iversen ha escrit:
>> Curiously, this keyword’s first name was “proposedEasyHack”, which at 
>> some point was found “confusing” by someone. I just find it a bit 
>> funny that a similar name is being proposed now… ;-)
> I too found needsEasyhackEvaluation a bit curious.
> But I have to admit that the current use:
>     keyword=easyhack and status=NEEDINFO
> is not the best way to do it.
> So adding a keyword seemed as a sensible option, I preferred just to 
> keep keyword=needsDevEval, since that can be used independent of easy 
> hack, but I leave that decision to the QA team.
“proposedEasyHack” was confusing at the time whitewords were used as the 
search engine didn't work well with ie. 'proposedEasyHack' and 
'easyhack'. However, now we use keywords and it works differently as the 
number of keywords is fixed and it searches for the entire word.

The point of changing the word to 'needsEasyHackValidation' is to limit 
its use to only easyhacks. 'needsDevEval' is too general and could be 
use in order cases where we don't want contributors to use it.
> the renaming of keyword=needAdvice to keyword=needsConfirmationAdvice 
> is a bit strange to me. If a bug is not confirmed, it has 
> status=UNCONFIRMED, so I am unsure why we keep 
> needAdvice/needsConfirmationAdvice
> We should be careful not to have too many keywords, and especially not 
> to make workflows into changing keywords.
Same here. According to the wiki, 'needAdvice' is meant to used for 
unconfirmed bugs which need help from a developer in order to get 
confirmed. Thus, using 'needsConfirmationAdvice' we limit its use to 
just that, avoiding contributors to use it somewhere else.


Xisco Faulí
Libreoffice QA Team

More information about the LibreOffice mailing list