[Mesa-dev] [status][help]pipe-video on Loongson3A(mipsel) platform with r600

fykcee1 at gmail.com fykcee1 at gmail.com
Tue Aug 2 00:00:31 PDT 2011

Hi all,

I've tried mesa-7.11rc4 with pipe-video patch on a Loongson3A based notebook:
 * CPU: 4-core MIPS64 compatible (Little-endian, 64bit kernel with an
o32 userland)
 * Graphics: RS780E

I tried h264、mpeg2 samples with mplayer -vo vdpau and xvmc, non of them works:
 * For h264, mplayer produces the following error messages:
[VD_FFMPEG] Trying pixfmt=0.
[vdpau] Failed creating VDPAU decoder: A catch-all error, used when no
other error code applies.
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
The selected video_out device is incompatible with this codec.
Try appending the scale filter to your filter list,
e.g. -vf spp,scale instead of -vf spp.
[h264_vdpau @ 0x2bddf1b8]decoding to PIX_FMT_NONE is not supported.
[h264_vdpau @ 0x2bddf1b8]decode_slice_header error
[h264_vdpau @ 0x2bddf1b8]no frame!
Error while decoding frame!

 * For mepg4, mplayer renders a corrupted
and produces the following:
[VD_FFMPEG] XVMC-accelerated MPEG-2.
Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
VO: [vdpau] 1920x1080 => 1920x1080 MPEG2 VDPAU acceleration
[mpegvideo_vdpau @ 0x2cb7b1b8]warning: first frame is no keyframe
V:   1.7   2/  2 ??% ??% ??,?% 0 0  [J
[mpegvideo_vdpau @ 0x2cb7b1b8]warning: first frame is no keyframe
V:   1.8   3/  3 ??% ??% ??,?% 0 0  [J

I also tried the master
branch(5b3c7199830b8eaac4df2f8c3f10d0e89b4bd5c5), and got the same

The test samples can be found at:
http://dev.lemote.com/files/upload/software/temp/video-test/   -- run
test.sh, it will play each sample with vdpau and xvmc, recording the

The detailed log message of the above test, including glxinfo can be
found at: http://dev.lemote.com/files/upload/software/temp/video-test.result.log.tar.bz2

Xorg info: http://dev.lemote.com/files/upload/software/temp/Xorg.0.log

Any idea? Thanks.

More info about the OS environment:
 1. Linux: 2.6.36
 2. OS: Based on debian squeeze, and ports some ubuntu graphical packages.
 2. X Server:
 3. xf86-video-ati: 6.14.2
 4. compiz: 0.8.6

- cee1

More information about the mesa-dev mailing list