[Mesa-dev] [status][help]pipe-video on Loongson3A(mipsel) platform with r600

Christian König deathsimple at vodafone.de
Tue Aug 2 03:40:43 PDT 2011


Am Dienstag, den 02.08.2011, 15:00 +0800 schrieb fykcee1 at gmail.com:
> I've tried mesa-7.11rc4 with pipe-video patch on a Loongson3A based notebook:
>  * CPU: 4-core MIPS64 compatible (Little-endian, 64bit kernel with an
> o32 userland)
>  * Graphics: RS780E
a bit unusual hardware configuration, but lets just see what we can do.
I'm not familiar with this kind of hardware so does "o32" mean you run
some x86 emulation, or are these native binaries?

> I tried h264、mpeg2 samples with mplayer -vo vdpau and xvmc, non of them works:
>  * For h264, mplayer produces the following error messages:
We currently don't have support for accelerated h264, so this test can't
succeed, but your test with the newmobcal1920 (mpeg2) demo should indeed

> Any idea? Thanks.
First question of all: Does glxgears work flawlessly? If yes (what I
assume) then the basics seems to work fine.

Please try mplayer just with the "-vo vdpau" option (without any "-vc"
option), this should result in software decoding with hardware colour
conversion and scaling, just the same thing that Xv does. Does this
gives you a picture?

Something else you should try is "export VDPAU_DEBUG=4", that should
give you a whole bunch of debug informations, please supply those to the


More information about the mesa-dev mailing list