[Mesa-dev] [status][help]pipe-video on Loongson3A(mipsel) platform with r600

Andy Furniss andyqos at ukfsn.org
Tue Aug 2 04:07:35 PDT 2011

fykcee1 at gmail.com wrote:
> Hi all,
> I've tried mesa-7.11rc4 with pipe-video patch on a Loongson3A based notebook:
>   * CPU: 4-core MIPS64 compatible (Little-endian, 64bit kernel with an
> o32 userland)
>   * Graphics: RS780E
> I tried h264、mpeg2 samples with mplayer -vo vdpau and xvmc, non of them works:
>   * For h264, mplayer produces the following error messages:

Only mpeg 1 and 2 are supported.

> [VD_FFMPEG] Trying pixfmt=0.
> [vdpau] Failed creating VDPAU decoder: A catch-all error, used when no
> other error code applies.

Does VDPAU_DRIVER=r600 vdpauinfo find your libs - if not you may need to 
copy them to where ever vdpau is looking.

> Any idea? Thanks.

Compiz may complicate things - I haven't tested with it.

Depending on how it was configured mplayer needs (probably) 
/etc/X11/XvMCConfig containing /path/to/your/lib/libXvMCr600.so

Your mplayer is old - maybe svn would be better if you can build it.

mplayer -v will tell you more about where it's looking for things like 
xvmc libs - but with newmobcal you will also get swamped with transport 
stream info.

vanilla xf86-video-ati: 6.14.2 does not have xvmc support, but I see 
from your Xorg log that you must be using a patched/other version.

Generally r600 pipe-video still has rendering and functional issues. If 
you just want to test fair enough, but if you are trying to make your 
system play h264 that it can't currently the best thing you could do is 
compile svn mplayer which now has ffmpeg h264 multithread support so -

mplayer -lavdopts threads=4 will use all of your cores.

More information about the mesa-dev mailing list