[Mesa-dev] [status][help]pipe-video on Loongson3A(mipsel) platform with r600

fykcee1 at gmail.com fykcee1 at gmail.com
Tue Aug 2 05:16:51 PDT 2011


Thanks for your reply.

2011/8/2 Andy Furniss <andyqos at ukfsn.org>:
> fykcee1 at gmail.com wrote:
>> Hi all,
>> I've tried mesa-7.11rc4 with pipe-video patch on a Loongson3A based
>> notebook:
>>  * CPU: 4-core MIPS64 compatible (Little-endian, 64bit kernel with an
>> o32 userland)
>>  * Graphics: RS780E
>> I tried h264、mpeg2 samples with mplayer -vo vdpau and xvmc, non of them
>> works:
>>  * For h264, mplayer produces the following error messages:
> Only mpeg 1 and 2 are supported.
>> [VD_FFMPEG] Trying pixfmt=0.
>> [vdpau] Failed creating VDPAU decoder: A catch-all error, used when no
>> other error code applies.
> Does VDPAU_DRIVER=r600 vdpauinfo find your libs - if not you may need to
> copy them to where ever vdpau is looking.
Yes. I specified a non-exists driver, mplayer quit early, complains
not find the non-exists so.

>> Any idea? Thanks.
> Compiz may complicate things - I haven't tested with it.
I've did the test without compiz, it seems not make any difference.

> Depending on how it was configured mplayer needs (probably)
> /etc/X11/XvMCConfig containing /path/to/your/lib/libXvMCr600.so
I add the path "/usr/lib/libXvMCr600.so" to /etc/X11/XvMCConfig, but
mplayer seems not invoke it (No r600 in strace or /proc/pid/maps).
Maybe I should try a newer version of mplayer.

> Your mplayer is old - maybe svn would be better if you can build it.
> mplayer -v will tell you more about where it's looking for things like xvmc
> libs - but with newmobcal you will also get swamped with transport stream
> info.
> vanilla xf86-video-ati: 6.14.2 does not have xvmc support, but I see from
> your Xorg log that you must be using a patched/other version.
Yes, some r600-related patches are backported from the master branch.

> Generally r600 pipe-video still has rendering and functional issues. If you
> just want to test fair enough, but if you are trying to make your system
> play h264 that it can't currently the best thing you could do is compile svn
> mplayer which now has ffmpeg h264 multithread support so -
> mplayer -lavdopts threads=4 will use all of your cores.
Got it, thanks.

- cee1

More information about the mesa-dev mailing list