[Mesa-dev] [status][help]pipe-video on Loongson3A(mipsel) platform with r600

fykcee1 at gmail.com fykcee1 at gmail.com
Tue Aug 2 23:13:01 PDT 2011


在 2011年8月2日 下午8:16,fykcee1 at gmail.com <fykcee1 at gmail.com> 写道:
>> Depending on how it was configured mplayer needs (probably)
>> /etc/X11/XvMCConfig containing /path/to/your/lib/libXvMCr600.so
> I add the path "/usr/lib/libXvMCr600.so" to /etc/X11/XvMCConfig, but
> mplayer seems not invoke it (No r600 in strace or /proc/pid/maps).
> Maybe I should try a newer version of mplayer.
My mplayer reads /usr/lib/XvMCConfig, after I providing that file,
libXvMCr600.so is loaded by mplayer.

>> Generally r600 pipe-video still has rendering and functional issues. If you
>> just want to test fair enough, but if you are trying to make your system
>> play h264 that it can't currently the best thing you could do is compile svn
>> mplayer which now has ffmpeg h264 multithread support so -
>> mplayer -lavdopts threads=4 will use all of your cores.
Tried, not make big difference at first glance. (P.S.  can mplayer
show fps in OSD?)
That still doesn't use all CPU power(even with thread=8) according to top.

- cee1

More information about the mesa-dev mailing list